MGASA-2014-0017
Dashboard / Vulnerabilities / MGASA-2014-0017
Summary: Updated ruby-i18n package fixes security vulnerability
Details: Cross-site scripting (XSS) vulnerability in exceptions.rb in the i18n gem before 0.6.6 for Ruby allows remote attackers to inject arbitrary web script or HTML via a crafted I18n::MissingTranslationData.new call (CVE-2013-4492).
References: https://advisories.mageia.org/MGASA-2014-0017.html, https://bugs.mageia.org/show_bug.cgi?id=12095, http://lists.opensuse.org/opensuse-updates/2013-12/msg00093.html
Affected packages
Package
Name: ruby-i18n
Purl: pkg:rpm/mageia/ruby-i18n?arch=source&distro=mageia-3
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -0.6.1-3.1.mga3
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
