MGASA-2015-0011

    Dashboard / Vulnerabilities / MGASA-2015-0011

    MGASA-2015-0011

    Published: 7 Jan 2015Last Modified: 16 Apr 2026
    Upstream:

    Summary: Updated apache packages fix CVE-2014-8109

    Details: Updated apache packages fix security vulnerability: mod_lua.c in the mod_lua module in the Apache HTTP Server through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory (CVE-2014-8109).

    Affected packages

    Package

    Name: apache

    Purl: pkg:rpm/mageia/apache?arch=source&distro=mageia-4

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.4.7-5.5.mga4

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High