MGASA-2015-0074
Dashboard / Vulnerabilities / MGASA-2015-0074
Summary: Updated ruby-sprockets packages fix CVE-2014-7819
Details: Updated ruby-sprockets packages fix security vulnerabilities: Multiple directory traversal vulnerabilities in server.rb in Sprockets 2.12.x before 2.12.3, allow remote attackers to determine the existence of files outside the application root via a ../ (dot dot slash) sequence with double slashes or URL encoding (CVE-2014-7819).
References: https://advisories.mageia.org/MGASA-2015-0074.html, https://bugs.mageia.org/show_bug.cgi?id=14664, http://lists.opensuse.org/opensuse-updates/2014-11/msg00111.html
Affected packages
Package
Name: ruby-sprockets
Purl: pkg:rpm/mageia/ruby-sprockets?arch=source&distro=mageia-4
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -2.10.0-4.1.mga4
Affected versions
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
