OESA-2022-1693

    Dashboard / Vulnerabilities / OESA-2022-1693

    OESA-2022-1693

    Published: 2 Jun 2022Last Modified: 18 Aug 2026
    Upstream:

    Summary: python-XStatic-jquery-ui security update

    Details: jquery-ui javascript library packaged for setuptools (easy_install) / pip. This package is intended to be used by **any** project that needs these files. It intentionally does **not** provide any extra code except some metadata **nor** has any extra requirements. You MAY use some minimal support code from the XStatic base package, if you like. You can find more info about the xstatic packaging way in the package `XStatic`. Security Fix(es): jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. The values passed to various `*Text` options are now always treated as pure text, not HTML. A workaround is to not accept the value of the `*Text` options from untrusted sources.(CVE-2021-41183)

    Affected packages

    Package

    Name: python-XStatic-jquery-ui

    Purl: pkg:rpm/openEuler/python-XStatic-jquery-ui&distro=openEuler-20.03-LTS-SP3

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1.12.1.1-2.oe1

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    OESA-2022-1693 | CVE-DB