SUSE-SU-2022:4631-1
Dashboard / Vulnerabilities / SUSE-SU-2022:4631-1
SUSE-SU-2022:4631-1
Summary: Security update for vim
Details: This update for vim fixes the following issues: Updated to version 9.0.1040: - CVE-2022-3491: vim: Heap-based Buffer Overflow prior to 9.0.0742 (bsc#1206028). - CVE-2022-3520: vim: Heap-based Buffer Overflow (bsc#1206071). - CVE-2022-3591: vim: Use After Free (bsc#1206072). - CVE-2022-4292: vim: Use After Free in GitHub repository vim/vim prior to 9.0.0882 (bsc#1206075). - CVE-2022-4293: vim: Floating Point Comparison with Incorrect Operator in GitHub repository vim/vim prior to 9.0.0804 (bsc#1206077). - CVE-2022-4141: vim: heap-buffer-overflow in alloc.c 246:11 (bsc#1205797). - CVE-2022-3705: vim: use after free in function qf_update_buffer of the file quickfix.c (bsc#1204779).
References: https://www.suse.com/support/update/announcement/2022/suse-su-20224631-1/, https://bugzilla.suse.com/1204779, https://bugzilla.suse.com/1205797, https://bugzilla.suse.com/1206028, https://bugzilla.suse.com/1206071, https://bugzilla.suse.com/1206072, https://bugzilla.suse.com/1206075, https://bugzilla.suse.com/1206077, https://www.suse.com/security/cve/CVE-2022-3491, https://www.suse.com/security/cve/CVE-2022-3520, https://www.suse.com/security/cve/CVE-2022-3591, https://www.suse.com/security/cve/CVE-2022-3705, https://www.suse.com/security/cve/CVE-2022-4141, https://www.suse.com/security/cve/CVE-2022-4292, https://www.suse.com/security/cve/CVE-2022-4293
Affected packages
Package
Name: vim
Purl: pkg:rpm/suse/vim&distro=SUSE%20Linux%20Enterprise%20Micro%205.3
Affected ranges
Type: ECOSYSTEM
Events:
