UBUNTU-CVE-2014-4670
Dashboard / Vulnerabilities / UBUNTU-CVE-2014-4670
UBUNTU-CVE-2014-4670
Published: 4 Jul 2014Last Modified: 22 Apr 2026
Upstream:
Aliases:
Summary:
Details: Use-after-free vulnerability in ext/spl/spl_dllist.c in the SPL component in PHP through 5.5.14 allows context-dependent attackers to cause a denial of service or possibly have unspecified other impact via crafted iterator usage within applications in certain web-hosting environments.
References: https://ubuntu.com/security/CVE-2014-4670, https://ubuntu.com/security/notices/USN-2276-1, https://www.cve.org/CVERecord?id=CVE-2014-4670
Affected packages
Package
Name: php5
Purl: pkg:deb/ubuntu/[email protected]+dfsg-1ubuntu4.3?arch=source&distro=trusty
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -5.5.9+dfsg-1ubuntu4.3
Affected versions
5.5.3+dfsg-1ubuntu2
5.5.3+dfsg-1ubuntu3
5.5.6+dfsg-1ubuntu1
5.5.6+dfsg-1ubuntu2
5.5.8+dfsg-2ubuntu1
5.5.9+dfsg-1ubuntu1
5.5.9+dfsg-1ubuntu2
5.5.9+dfsg-1ubuntu3
5.5.9+dfsg-1ubuntu4
5.5.9+dfsg-1ubuntu4.1
5.5.9+dfsg-1ubuntu4.2
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
