UBUNTU-CVE-2014-4721

    Dashboard / Vulnerabilities / UBUNTU-CVE-2014-4721

    UBUNTU-CVE-2014-4721

    Published: 6 Jul 2014Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: The phpinfo implementation in ext/standard/info.c in PHP before 5.4.30 and 5.5.x before 5.5.14 does not ensure use of the string data type for the PHP_AUTH_PW, PHP_AUTH_TYPE, PHP_AUTH_USER, and PHP_SELF variables, which might allow context-dependent attackers to obtain sensitive information from process memory by using the integer data type with crafted values, related to a "type confusion" vulnerability, as demonstrated by reading a private SSL key in an Apache HTTP Server web-hosting environment with mod_ssl and a PHP 5.3.x mod_php.

    Affected packages

    Package

    Name: php5

    Purl: pkg:deb/ubuntu/[email protected]+dfsg-1ubuntu4.3?arch=source&distro=trusty

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -5.5.9+dfsg-1ubuntu4.3

    Affected versions

    5.5.3+dfsg-1ubuntu2
    5.5.3+dfsg-1ubuntu3
    5.5.6+dfsg-1ubuntu1
    5.5.6+dfsg-1ubuntu2
    5.5.8+dfsg-2ubuntu1
    5.5.9+dfsg-1ubuntu1
    5.5.9+dfsg-1ubuntu2
    5.5.9+dfsg-1ubuntu3
    5.5.9+dfsg-1ubuntu4
    5.5.9+dfsg-1ubuntu4.1
    5.5.9+dfsg-1ubuntu4.2

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High