UBUNTU-CVE-2014-8636

    Dashboard / Vulnerabilities / UBUNTU-CVE-2014-8636

    UBUNTU-CVE-2014-8636

    Published: 14 Jan 2015Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: The XrayWrapper implementation in Mozilla Firefox before 35.0 and SeaMonkey before 2.32 does not properly interact with a DOM object that has a named getter, which might allow remote attackers to execute arbitrary JavaScript code with chrome privileges via unspecified vectors.

    Affected packages

    Package

    Name: firefox

    Purl: pkg:deb/ubuntu/[email protected]+build3-0ubuntu0.14.04.2?arch=source&distro=trusty

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -35.0+build3-0ubuntu0.14.04.2

    Affected versions

    24.0+build1-0ubuntu1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High