UBUNTU-CVE-2015-0204

    Dashboard / Vulnerabilities / UBUNTU-CVE-2015-0204

    UBUNTU-CVE-2015-0204

    Published: 8 Jan 2015Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: The ssl3_get_key_exchange function in s3_clnt.c in OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k allows remote SSL servers to conduct RSA-to-EXPORT_RSA downgrade attacks and facilitate brute-force decryption by offering a weak ephemeral RSA key in a noncompliant role, related to the "FREAK" issue. NOTE: the scope of this CVE is only client code based on OpenSSL, not EXPORT_RSA issues associated with servers or other TLS implementations.

    Affected packages

    Package

    Name: openssl

    Purl: pkg:deb/ubuntu/[email protected]?arch=source&distro=trusty

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1.0.1f-1ubuntu2.8

    Affected versions

    1.0.1e-3ubuntu1
    1.0.1e-4ubuntu1
    1.0.1e-4ubuntu2
    1.0.1e-4ubuntu3
    1.0.1e-4ubuntu4
    1.0.1f-1ubuntu1
    1.0.1f-1ubuntu2
    1.0.1f-1ubuntu2.1
    1.0.1f-1ubuntu2.2
    1.0.1f-1ubuntu2.3
    1.0.1f-1ubuntu2.4
    1.0.1f-1ubuntu2.5
    1.0.1f-1ubuntu2.7

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High