UBUNTU-CVE-2015-1029
Dashboard / Vulnerabilities / UBUNTU-CVE-2015-1029
Summary:
Details: The puppetlabs-stdlib module 2.1 through 3.0 and 4.1.0 through 4.5.x before 4.5.1 for Puppet 2.8.8 and earlier allows remote authenticated users to gain privileges or obtain sensitive information by prepopulating the fact cache.
References: https://ubuntu.com/security/CVE-2015-1029, http://puppetlabs.com/security/cve/cve-2015-1029, http://secunia.com/advisories/62328, https://www.cve.org/CVERecord?id=CVE-2015-1029
Affected packages
Package
Name: puppet-module-puppetlabs-stdlib
Purl: pkg:deb/ubuntu/[email protected]?arch=source&distro=xenial
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -4.10.0-1
Affected versions
4.3.2-1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
