UBUNTU-CVE-2022-25147
Dashboard / Vulnerabilities / UBUNTU-CVE-2022-25147
UBUNTU-CVE-2022-25147
Published: 31 Jan 2023Last Modified: 22 Apr 2026
Upstream:
Aliases:
Summary:
Details: Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.
References: https://ubuntu.com/security/CVE-2022-25147, https://lists.apache.org/thread/np5gjqlohc4f62lr09vrn61vl44cylh8, https://github.com/apache/apr/commit/850cc4f69639ac9f1c1c9767efaf4883ee3217ce, https://ubuntu.com/security/notices/USN-5870-1, https://www.cve.org/CVERecord?id=CVE-2022-25147
Affected packages
Package
Name: apr-util
Purl: pkg:deb/ubuntu/[email protected]~esm2?arch=source&distro=trusty/esm
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -1.5.3-1ubuntu0.1~esm2
Affected versions
1.5.2-1
1.5.2-1build1
1.5.2-2ubuntu1
1.5.3-1
1.5.3-1ubuntu0.1~esm1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
