UBUNTU-CVE-2022-38784

    Dashboard / Vulnerabilities / UBUNTU-CVE-2022-38784

    UBUNTU-CVE-2022-38784

    Published: 30 Aug 2022Last Modified: 17 Oct 2026

    Summary:

    Details: Poppler prior to and including 22.08.0 contains an integer overflow in the JBIG2 decoder (JBIG2Stream::readTextRegionSeg() in JBIGStream.cc). Processing a specially crafted PDF file or JBIG2 image could lead to a crash or the execution of arbitrary code. This is similar to the vulnerability described by CVE-2022-38171 in Xpdf.

    Affected packages

    Package

    Name: poppler

    Purl: pkg:deb/ubuntu/poppler?arch=source&distro=esm-infra%2Fxenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -0.41.0-0ubuntu1.16+esm2

    Affected versions

    0.33.0-0ubuntu3

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High