UBUNTU-CVE-2023-23915

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-23915

    UBUNTU-CVE-2023-23915

    Published: 15 Feb 2023Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality to behave incorrectly when multiple URLs are requested in parallel. Using its HSTS support, curl can be instructed to use HTTPS instead of using an insecure clear-text HTTP step even when HTTP is provided in the URL. This HSTS mechanism would however surprisingly fail when multiple transfers are done in parallel as the HSTS cache file gets overwritten by the most recentlycompleted transfer. A later HTTP-only transfer to the earlier host name would then *not* get upgraded properly to HSTS.

    Affected packages

    Package

    Name: curl

    Purl: pkg:deb/ubuntu/[email protected]?arch=source&distro=jammy

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -7.81.0-1ubuntu1.8

    Affected versions

    7.74.0-1.3ubuntu2
    7.74.0-1.3ubuntu3

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High