UBUNTU-CVE-2023-23946

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-23946

    UBUNTU-CVE-2023-23946

    Published: 14 Feb 2023Last Modified: 4 Feb 2026
    Upstream:
    Aliases:

    Summary:

    Details: Git, a revision control system, is vulnerable to path traversal prior to versions 2.39.2, 2.38.4, 2.37.6, 2.36.5, 2.35.7, 2.34.7, 2.33.7, 2.32.6, 2.31.7, and 2.30.8. By feeding a crafted input to `git apply`, a path outside the working tree can be overwritten as the user who is running `git apply`. A fix has been prepared and will appear in v2.39.2, v2.38.4, v2.37.6, v2.36.5, v2.35.7, v2.34.7, v2.33.7, v2.32.6, v2.31.7, and v2.30.8. As a workaround, use `git apply --stat` to inspect a patch before applying; avoid applying one that creates a symbolic link and then creates a file beyond the symbolic link.

    Affected packages

    Package

    Name: git

    Purl: pkg:deb/ubuntu/git@1:2.7.4-0ubuntu1.10+esm5?arch=source&distro=esm-infra/xenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1:2.7.4-0ubuntu1.10+esm5

    Affected versions

    1:2.5.0-1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2023-23946 | CVE-DB