UBUNTU-CVE-2023-25567

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-25567

    UBUNTU-CVE-2023-25567

    Published: 14 Feb 2023Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.

    Affected packages

    Package

    Name: gss-ntlmssp

    Purl: pkg:deb/ubuntu/[email protected]~ubuntu0.16.04.1+esm1?arch=source&distro=esm-apps/xenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -0.7.0-3~ubuntu0.16.04.1+esm1

    Affected versions

    0.6.0-1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2023-25567 | CVE-DB