UBUNTU-CVE-2023-25725

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-25725

    UBUNTU-CVE-2023-25725

    Published: 14 Feb 2023Last Modified: 4 Feb 2026

    Summary:

    Details: HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

    Affected packages

    Package

    Name: haproxy

    Purl: pkg:deb/ubuntu/[email protected]+esm2?arch=source&distro=esm-infra/xenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -1.6.3-1ubuntu0.3+esm2

    Affected versions

    1.5.14-1
    1.5.15-1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2023-25725 | CVE-DB