UBUNTU-CVE-2023-42282
Dashboard / Vulnerabilities / UBUNTU-CVE-2023-42282
UBUNTU-CVE-2023-42282
Published: 9 Feb 2024Last Modified: 4 Feb 2026
Upstream:
Aliases:
Summary:
Details: The ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally routable via isPublic.
References: https://ubuntu.com/security/CVE-2023-42282, https://huntr.com/bounties/bfc3b23f-ddc0-4ee7-afab-223b07115ed3/, https://cosmosofcyberspace.github.io/npm_ip_cve/npm_ip_cve.html, https://ubuntu.com/security/notices/USN-6643-1, https://www.cve.org/CVERecord?id=CVE-2023-42282
Affected packages
Package
Name: node-ip
Purl: pkg:deb/ubuntu/[email protected]~esm1?arch=source&distro=esm-apps/bionic
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -1.1.5-1ubuntu0.1~esm1
Affected versions
1.1.5-1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
