UBUNTU-CVE-2023-47090

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-47090

    UBUNTU-CVE-2023-47090

    Published: 30 Oct 2023Last Modified: 16 Jul 2025
    Upstream:

    Summary:

    Details: NATS nats-server before 2.9.23 and 2.10.x before 2.10.2 has an authentication bypass. An implicit $G user in an authorization block can sometimes be used for unauthenticated access, even when the intention of the configuration was for each user to have an account. The earliest affected version is 2.2.0.

    Affected packages

    Package

    Name: nats-server

    Purl: pkg:deb/ubuntu/[email protected]?arch=source&distro=noble

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.10.3-1

    Affected versions

    2.9.19-1build1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High