UBUNTU-CVE-2023-6779

    Dashboard / Vulnerabilities / UBUNTU-CVE-2023-6779

    UBUNTU-CVE-2023-6779

    Published: 31 Jan 2024Last Modified: 22 Apr 2026
    Upstream:
    Aliases:

    Summary:

    Details: An off-by-one heap-based buffer overflow was found in the __vsyslog_internal function of the glibc library. This function is called by the syslog and vsyslog functions. This issue occurs when these functions are called with a message bigger than INT_MAX bytes, leading to an incorrect calculation of the buffer size to store the message, resulting in an application crash. This issue affects glibc 2.37 and newer.

    Affected packages

    Package

    Name: glibc

    Purl: pkg:deb/ubuntu/[email protected]?arch=source&distro=noble

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2.39-0ubuntu1

    Affected versions

    2.38-1ubuntu6

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High