UBUNTU-CVE-2024-22667

    Dashboard / Vulnerabilities / UBUNTU-CVE-2024-22667

    UBUNTU-CVE-2024-22667

    Published: 5 Feb 2024Last Modified: 4 Feb 2026
    Upstream:
    Aliases:

    Summary:

    Details: Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c calls sprintf to write to the error buffer that is passed down to the option callback functions.

    Affected packages

    Package

    Name: vim

    Purl: pkg:deb/ubuntu/vim@2:7.4.052-1ubuntu3.1+esm16?arch=source&distro=trusty/esm

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -2:7.4.052-1ubuntu3.1+esm16

    Affected versions

    2:7.4.000-1ubuntu2
    2:7.4.052-1ubuntu1
    2:7.4.052-1ubuntu2
    2:7.4.052-1ubuntu3
    2:7.4.052-1ubuntu3.1
    2:7.4.052-1ubuntu3.1+esm1
    2:7.4.052-1ubuntu3.1+esm3
    2:7.4.052-1ubuntu3.1+esm4
    2:7.4.052-1ubuntu3.1+esm5
    2:7.4.052-1ubuntu3.1+esm6
    2:7.4.052-1ubuntu3.1+esm7
    2:7.4.052-1ubuntu3.1+esm8
    2:7.4.052-1ubuntu3.1+esm9
    2:7.4.052-1ubuntu3.1+esm10
    2:7.4.052-1ubuntu3.1+esm11
    2:7.4.052-1ubuntu3.1+esm12
    2:7.4.052-1ubuntu3.1+esm13
    2:7.4.052-1ubuntu3.1+esm14
    2:7.4.052-1ubuntu3.1+esm15

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High