UBUNTU-CVE-2024-23807

    Dashboard / Vulnerabilities / UBUNTU-CVE-2024-23807

    UBUNTU-CVE-2024-23807

    Published: 29 Feb 2024Last Modified: 22 Apr 2026
    Upstream:

    Summary:

    Details: The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.

    Affected packages

    Package

    Name: xerces-c

    Purl: pkg:deb/ubuntu/[email protected]+debian-1ubuntu0.1~esm2?arch=source&distro=esm-apps/xenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.1.3+debian-1ubuntu0.1~esm2

    Affected versions

    3.1.1-5.1
    3.1.2+debian-1
    3.1.3+debian-1
    3.1.3+debian-1ubuntu0.1~esm1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High