UBUNTU-CVE-2024-24474
Dashboard / Vulnerabilities / UBUNTU-CVE-2024-24474
UBUNTU-CVE-2024-24474
Published: 20 Feb 2024Last Modified: 4 Feb 2026
Upstream:
Aliases:
Summary:
Details: QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI command when an expected non-DMA transfer length is less than the length of the available FIFO data. This occurs in esp_do_nodma in hw/scsi/esp.c because of an underflow of async_len.
References: https://ubuntu.com/security/CVE-2024-24474, https://gist.github.com/1047524396/5ce07b9d387095c276b1cd234ae5615e, https://www.cve.org/CVERecord?id=CVE-2024-24474, https://ubuntu.com/security/notices/USN-6954-1
Affected packages
Package
Name: qemu
Purl: pkg:deb/ubuntu/qemu@1:6.2+dfsg-2ubuntu6.22?arch=source&distro=jammy
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -1:6.2+dfsg-2ubuntu6.22
Affected versions
1:6.0+dfsg-2expubuntu1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
