UBUNTU-CVE-2024-26146
Dashboard / Vulnerabilities / UBUNTU-CVE-2024-26146
UBUNTU-CVE-2024-26146
Summary:
Details: Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.
References: https://ubuntu.com/security/CVE-2024-26146, https://github.com/rack/rack/releases/tag/v2.2.8.1, https://ubuntu.com/security/notices/USN-6689-1, https://www.cve.org/CVERecord?id=CVE-2024-26146, https://ubuntu.com/security/notices/USN-6837-1, https://ubuntu.com/security/notices/USN-6837-2, https://ubuntu.com/security/notices/USN-7036-1
Affected packages
Package
Name: ruby-rack
Purl: pkg:deb/ubuntu/[email protected]+deb8u3ubuntu1~esm8?arch=source&distro=trusty/esm
Affected ranges
Type: ECOSYSTEM
Events:
