UBUNTU-CVE-2025-25724

    Dashboard / Vulnerabilities / UBUNTU-CVE-2025-25724

    UBUNTU-CVE-2025-25724

    Published: 2 Mar 2025Last Modified: 22 Apr 2026

    Summary:

    Details: list_item_verbose in tar/util.c in libarchive through 3.7.7 does not check an strftime return value, which can lead to a denial of service or unspecified other impact via a crafted TAR archive that is read with a verbose value of 2. For example, the 100-byte buffer may not be sufficient for a custom locale.

    Affected packages

    Package

    Name: libarchive

    Purl: pkg:deb/ubuntu/[email protected]+esm4?arch=source&distro=esm-infra-legacy/trusty

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.1.2-7ubuntu2.8+esm4

    Affected versions

    3.1.2-5ubuntu1
    3.1.2-7ubuntu1
    3.1.2-7ubuntu2
    3.1.2-7ubuntu2.1
    3.1.2-7ubuntu2.2
    3.1.2-7ubuntu2.3
    3.1.2-7ubuntu2.4
    3.1.2-7ubuntu2.6
    3.1.2-7ubuntu2.7
    3.1.2-7ubuntu2.8
    3.1.2-7ubuntu2.8+esm1
    3.1.2-7ubuntu2.8+esm3

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2025-25724 | CVE-DB