UBUNTU-CVE-2025-46337

    Dashboard / Vulnerabilities / UBUNTU-CVE-2025-46337

    UBUNTU-CVE-2025-46337

    Published: 1 May 2025Last Modified: 4 Nov 2026

    Summary:

    Details: ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

    Affected packages

    Package

    Name: libphp-adodb

    Purl: pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Fxenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -5.20.3-1ubuntu1+esm2

    Affected versions

    5.18a-1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2025-46337 | CVE-DB