UBUNTU-CVE-2025-5916

    Dashboard / Vulnerabilities / UBUNTU-CVE-2025-5916

    UBUNTU-CVE-2025-5916

    Published: 9 Jun 2025Last Modified: 22 Apr 2026

    Summary:

    Details: A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.

    Affected packages

    Package

    Name: libarchive

    Purl: pkg:deb/ubuntu/[email protected]+esm4?arch=source&distro=esm-infra-legacy/trusty

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.1.2-7ubuntu2.8+esm4

    Affected versions

    3.1.2-5ubuntu1
    3.1.2-7ubuntu1
    3.1.2-7ubuntu2
    3.1.2-7ubuntu2.1
    3.1.2-7ubuntu2.2
    3.1.2-7ubuntu2.3
    3.1.2-7ubuntu2.4
    3.1.2-7ubuntu2.6
    3.1.2-7ubuntu2.7
    3.1.2-7ubuntu2.8
    3.1.2-7ubuntu2.8+esm1
    3.1.2-7ubuntu2.8+esm3

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High