UBUNTU-CVE-2025-59933

    Dashboard / Vulnerabilities / UBUNTU-CVE-2025-59933

    UBUNTU-CVE-2025-59933

    Published: 29 Sept 2025Last Modified: 4 Nov 2026
    Upstream:
    Aliases:

    Summary:

    Details: libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

    Affected packages

    Package

    Name: vips

    Purl: pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fbionic

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -8.4.5-1ubuntu0.1~esm2

    Affected versions

    8.4.5-1build1
    8.4.5-1ubuntu0.1~esm1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2025-59933 | CVE-DB