UBUNTU-CVE-2025-66034

    Dashboard / Vulnerabilities / UBUNTU-CVE-2025-66034

    UBUNTU-CVE-2025-66034

    Published: 29 Nov 2025Last Modified: 20 May 2026
    Upstream:
    Aliases:

    Summary:

    Details: fontTools is a library for manipulating fonts, written in Python. In versions from 4.33.0 to before 4.60.2, the fonttools varLib (or python3 -m fontTools.varLib) script has an arbitrary file write vulnerability that leads to remote code execution when a malicious .designspace file is processed. The vulnerability affects the main() code path of fontTools.varLib, used by the fonttools varLib CLI and any code that invokes fontTools.varLib.main(). This issue has been patched in version 4.60.2.

    Affected packages

    Package

    Name: fonttools

    Purl: pkg:deb/ubuntu/fonttools?arch=source&distro=esm-apps%2Fnoble

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -4.46.0-1ubuntu0.1~esm1

    Affected versions

    4.38.0-1build1
    4.38.0-1build2

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2025-66034 | CVE-DB