UBUNTU-CVE-2026-100300
Dashboard / Vulnerabilities / UBUNTU-CVE-2026-100300
Summary:
Details: Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
References: https://ubuntu.com/security/CVE-2026-100300, https://www.cve.org/CVERecord?id=CVE-2026-100300, https://lists.apache.org/thread.html/09pgg7rcpzz44noxgtvpzstwt8fmvsb0, http://www.openwall.com/lists/oss-security/2026/11/03/11
Affected packages
Package
Name: zookeeper
Purl: pkg:deb/ubuntu/zookeeper?arch=source&distro=esm-infra-legacy%2Ftrusty
Affected ranges
Type: ECOSYSTEM
Events:
