UBUNTU-CVE-2026-111821
Dashboard / Vulnerabilities / UBUNTU-CVE-2026-111821
Summary:
Details: Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
References: https://ubuntu.com/security/CVE-2026-111821, https://www.cve.org/CVERecord?id=CVE-2026-111821, https://lists.apache.org/thread/p8gxq66lmztkrls74wkz3xh9chqd0pwl, http://www.openwall.com/lists/oss-security/2026/11/03/19
Affected packages
Package
Name: activemq
Purl: pkg:deb/ubuntu/activemq?arch=source&distro=esm-apps%2Fxenial
Affected ranges
Type: ECOSYSTEM
Events:
