UBUNTU-CVE-2026-26961
Dashboard / Vulnerabilities / UBUNTU-CVE-2026-26961
UBUNTU-CVE-2026-26961
Summary:
Details: Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser extracts the boundary parameter from multipart/form-data using a greedy regular expression. When a Content-Type header contains multiple boundary parameters, Rack selects the last one rather than the first. In deployments where an upstream proxy, WAF, or intermediary interprets the first boundary parameter, this mismatch can allow an attacker to smuggle multipart content past upstream inspection and have Rack parse a different body structure than the intermediary validated. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.
References: https://ubuntu.com/security/CVE-2026-26961, https://www.cve.org/CVERecord?id=CVE-2026-26961, https://github.com/rack/rack/security/advisories/GHSA-vgpv-f759-9wx3, https://ubuntu.com/security/notices/USN-8182-1, https://ubuntu.com/security/notices/USN-8989-1
Affected packages
Package
Name: ruby-rack
Purl: pkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-infra-legacy%2Ftrusty
Affected ranges
Type: ECOSYSTEM
Events:
