UBUNTU-CVE-2026-33327
Dashboard / Vulnerabilities / UBUNTU-CVE-2026-33327
UBUNTU-CVE-2026-33327
Published: 20 Jul 2026Last Modified: 4 Nov 2026
Upstream:
Aliases:
Summary:
Details: libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.
References: https://ubuntu.com/security/CVE-2026-33327, https://www.cve.org/CVERecord?id=CVE-2026-33327, https://github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x, https://github.com/libvips/libvips/pull/4934, https://ubuntu.com/security/notices/USN-8994-1
Affected packages
Package
Name: vips
Purl: pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fbionic
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -8.4.5-1ubuntu0.1~esm2
Affected versions
8.4.5-1build1
8.4.5-1ubuntu0.1~esm1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
