UBUNTU-CVE-2026-33328

    Dashboard / Vulnerabilities / UBUNTU-CVE-2026-33328

    UBUNTU-CVE-2026-33328

    Published: 20 Jul 2026Last Modified: 4 Nov 2026
    Upstream:
    Aliases:

    Summary:

    Details: libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.

    Affected packages

    Package

    Name: vips

    Purl: pkg:deb/ubuntu/vips?arch=source&distro=esm-apps%2Fnoble

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -8.15.1-1.1ubuntu0.1~esm2

    Affected versions

    8.14.3-1
    8.14.5-1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2026-33328 | CVE-DB