UBUNTU-CVE-2026-33515

    Dashboard / Vulnerabilities / UBUNTU-CVE-2026-33515

    UBUNTU-CVE-2026-33515

    Published: 26 Mar 2026Last Modified: 21 Oct 2026

    Summary:

    Details: Squid is a caching proxy for the Web. Prior to version 7.5, due to improper input validation, Squid is vulnerable to out of bounds read when handling ICP traffic. This problem allows a remote attacker to receive small amounts of memory potentially containing sensitive information when responding with errors to invalid ICP requests. This attack is limited to Squid deployments that explicitly enable ICP support (i.e. configure non-zero `icp_port`). This problem cannot be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.

    Affected packages

    Package

    Name: squid3

    Purl: pkg:deb/ubuntu/squid3?arch=source&distro=esm-infra-legacy%2Fxenial

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.5.12-1ubuntu7.16+esm7

    Affected versions

    3.3.8-1ubuntu16
    3.3.8-1ubuntu17

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    UBUNTU-CVE-2026-33515 | CVE-DB