BIT-spark-2022-31777

    Dashboard / Vulnerabilities / BIT-spark-2022-31777

    BIT-spark-2022-31777

    Published: 6 Mar 2024Last Modified: 8 Sept 2026

    Summary: Apache Spark XSS vulnerability in log viewer UI Javascript

    Details: A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Affected packages

    Package

    Name: spark

    Purl: pkg:bitnami/spark

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 0
    Fixed -3.2.2

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High