PYSEC-2022-42976

    Dashboard / Vulnerabilities / PYSEC-2022-42976

    PYSEC-2022-42976

    Published: 1 Nov 2022Last Modified: 10 Jun 2026

    Summary:

    Details: A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

    Affected packages

    Package

    Name: pyspark

    Purl: pkg:pypi/pyspark

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -3.2.2

    Affected versions

    2.1.1
    2.1.2
    2.1.3

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    PYSEC-2022-42976 | CVE-DB