BIT-tensorflow-2020-15210

    Dashboard / Vulnerabilities / BIT-tensorflow-2020-15210

    BIT-tensorflow-2020-15210

    Published: 6 Mar 2024Last Modified: 8 Sept 2026

    Summary: Segmentation fault in tensorflow-lite

    Details: In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

    Affected packages

    Package

    Name: tensorflow

    Purl: pkg:bitnami/tensorflow

    Affected ranges

    Type: SEMVER

    Events:

    Introduced- 0
    Fixed -1.15.4

    Affected versions

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    BIT-tensorflow-2020-15210 | CVE-DB