PYSEC-2020-133

    Dashboard / Vulnerabilities / PYSEC-2020-133

    PYSEC-2020-133

    Published: 25 Sept 2020Last Modified: 6 Dec 2023

    Summary:

    Details: In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

    Affected packages

    Package

    Name: tensorflow

    Purl: pkg:pypi/tensorflow

    Affected ranges

    Type: GIT

    Events:

    Affected versions

    0.12.0rc0
    0.12.0rc1
    0.12.0
    0.12.1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    PYSEC-2020-133 | CVE-DB