CVE-2024-23673

    Dashboard / Vulnerabilities / CVE-2024-23673

    CVE-2024-23673

    Published: 6 Feb 2024Last Modified: 28 Oct 2026

    Summary: Apache Sling Servlets Resolver: Malicious code execution via path traversal

    Details: Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script.  Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.

    Affected packages

    Package

    Name:

    Purl:

    Affected ranges

    Type: GIT

    Events:

    Affected versions

    org.apache.sling.servlets.resolver-2.10.0
    org.apache.sling.servlets.resolver-2.9.14
    org.apache.sling.servlets.resolver-2.9.12
    org.apache.sling.servlets.resolver-2.9.10
    org.apache.sling.servlets.resolver-2.9.8
    org.apache.sling.servlets.resolver-2.9.6
    org.apache.sling.servlets.resolver-2.9.4
    org.apache.sling.servlets.resolver-2.9.2
    org.apache.sling.servlets.resolver-2.9.0
    org.apache.sling.servlets.resolver-2.8.2
    org.apache.sling.servlets.resolver-2.8.0
    org.apache.sling.servlets.resolver-2.7.14
    org.apache.sling.servlets.resolver-2.7.12
    org.apache.sling.servlets.resolver-2.7.10
    org.apache.sling.servlets.resolver-2.7.8
    org.apache.sling.servlets.resolver-2.7.6
    org.apache.sling.servlets.resolver-2.7.4
    org.apache.sling.servlets.resolver-2.7.2
    org.apache.sling.servlets.resolver-2.7.0
    org.apache.sling.servlets.resolver-2.6.4
    org.apache.sling.servlets.resolver-2.6.2
    org.apache.sling.servlets.resolver-2.6.0
    org.apache.sling.servlets.resolver-2.5.8
    org.apache.sling.servlets.resolver-2.5.6
    org.apache.sling.servlets.resolver-2.5.4
    org.apache.sling.servlets.resolver-2.5.2
    org.apache.sling.servlets.resolver-2.4.24
    org.apache.sling.servlets.resolver-2.4.22
    org.apache.sling.servlets.resolver-2.4.20
    org.apache.sling.servlets.resolver-2.4.18
    org.apache.sling.servlets.resolver-2.4.16

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High