GHSA-9v8h-qqgm-4m35

    Dashboard / Vulnerabilities / GHSA-9v8h-qqgm-4m35

    GHSA-9v8h-qqgm-4m35

    Published: 22 Oct 2026Last Modified: 5 Nov 2026

    Summary: Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

    Details: A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

    References: https://nvd.nist.gov/vuln/detail/CVE-2026-111497, https://github.com/dotnet/announcements/issues/494, https://github.com/google/brotli/commit/da9806362874b9bd4b552a3af360b5d6347beb12, https://github.com/google/brotli/commit/b418fa81c48262a86a95332b0bc6d62c30aa78b6, https://github.com/google/brotli/commit/50a9b70a4d5e1443fc40927952276b68fffa83a0, https://github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b, https://github.com/pypa/advisory-database/tree/main/vulns/brotlicffi/PYSEC-2026-4323.yaml, https://lists.debian.org/debian-lts-announce/2026/10/msg00049.html, https://nodejs.org/en/blog/vulnerability/october-2026-security-releases, https://nodejs.org/en/blog/vulnerability/october-2026-security-releases#nodejs-brotli-decoder-out-of-bounds-write-permits-remote-code-execution-cve-2026-111497---high, https://opensourcemalware.com/blog/node2shell-affects-python, https://patchtheplanet.org/brotli, https://pypi.org/project/Brotli, https://pypi.org/project/brotlicffi, https://www.aikido.dev/blog/node2shell-nodejs-brotli-rce-cve-2026-111497, https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-111497, https://www.cve.org/CVERecord?id=CVE-2026-111497, https://github.com/pypa/advisory-database/tree/main/vulns/brotli/PYSEC-2026-4322.yaml, https://github.com/google/brotli/releases/tag/v1.2.1, https://github.com/google/brotli/releases/tag/v1.1.1, https://github.com/google/brotli/releases/tag/v1.0.10, https://github.com/google/brotli, https://github.com/andybalholm/brotli/releases/tag/v1.2.7, https://github.com/advisories/GHSA-9v8h-qqgm-4m35, https://ellio.tech/en/blog/node2shell-cve-2026-111497-rce-on-stock-nodejs-builds, https://cert-portal.siemens.com/productcert/html/ssa-898633.html, https://cert-portal.siemens.com/productcert/html/ssa-443410.html, https://cert-portal.siemens.com/productcert/html/ssa-045512.html, https://broccoli2shell.com, http://www.openwall.com/lists/oss-security/2026/10/23/25, http://www.openwall.com/lists/oss-security/2026/10/24/6, http://www.openwall.com/lists/oss-security/2026/10/26/12, http://www.openwall.com/lists/oss-security/2026/10/26/13, http://www.openwall.com/lists/oss-security/2026/10/26/16

    Affected packages

    Package

    Name: brotli

    Purl: pkg:pypi/brotli

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 1.0.3
    Fixed -1.2.1

    Affected versions

    1.0.4
    1.0.6
    1.0.7
    1.0.8
    1.0.9

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High