GHSA-mq26-g339-26xf

    Dashboard / Vulnerabilities / GHSA-mq26-g339-26xf

    GHSA-mq26-g339-26xf

    Published: 25 Oct 2023Last Modified: 10 Sept 2026

    Summary: Command Injection in pip when used with Mercurial

    Details: When installing a package from a Mercurial VCS URL, e.g. `pip install hg+...`, with pip prior to v23.3, the specified Mercurial revision could be used to inject arbitrary configuration options to the `hg clone` call (e.g. `--config`). Controlling the Mercurial configuration can modify how and which repository is installed. This vulnerability does not affect users who aren't installing from Mercurial.

    Affected packages

    Package

    Name: pip

    Purl: pkg:pypi/pip

    Affected ranges

    Type: ECOSYSTEM

    Events:

    Introduced- 0
    Fixed -23.3

    Affected versions

    0.2
    0.2.1

    Common Vulnerability Scoring System

    Attack Vector
    Network
    Adjacent
    Local
    Physical
    Privileges Required
    None
    Low
    High
    User Interaction
    None
    Required
    Scope
    Unchanged
    Changed
    Confidentiality
    None
    Low
    High
    Integrity
    None
    Low
    High
    Availability
    None
    Low
    High
    GHSA-mq26-g339-26xf | CVE-DB