PYSEC-2023-228
Dashboard / Vulnerabilities / PYSEC-2023-228
PYSEC-2023-228
Published: 25 Oct 2023Last Modified: 10 Jun 2026
Aliases:
Summary:
Details: When installing a package from a Mercurial VCS URL (ie "pip install hg+...") with pip prior to v23.3, the specified Mercurial revision could be used to inject arbitrary configuration options to the "hg clone" call (ie "--config"). Controlling the Mercurial configuration can modify how and which repository is installed. This vulnerability does not affect users who aren't installing from Mercurial.
References: https://mail.python.org/archives/list/[email protected]/thread/F4PL35U6X4VVHZ5ILJU3PWUWN7H7LZXL/, https://github.com/pypa/pip/pull/12306, https://github.com/advisories/GHSA-mq26-g339-26xf
Affected packages
Package
Name: pip
Purl: pkg:pypi/pip
Affected ranges
Type: ECOSYSTEM
Events:
Introduced- 0
Fixed -23.3
Affected versions
0.2
0.2.1
Common Vulnerability Scoring System
Attack Vector
Network
Adjacent
Local
Physical
Privileges Required
None
Low
High
User Interaction
None
Required
Scope
Unchanged
Changed
Confidentiality
None
Low
High
Integrity
None
Low
High
Availability
None
Low
High
